In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 05, 2025 - 23:30 UTC
Scheduled - We will be performing our weekly system maintenance from 4:30pm - 7pm PDT on Fri(11:30pm-2:00am GMT Saturday). You should still be able to access the site, but some functionality may be temporarily unavailable. We apologize for any inconvenience this may cause, and thank you very much for your continued support.
Apr 5, 202523:30 - Apr 6, 202502:00 UTC
Locations
Under Maintenance
90 days ago
99.92
% uptime
Today
US
Under Maintenance
90 days ago
99.95
% uptime
Today
Frankfurt
Under Maintenance
90 days ago
99.89
% uptime
Today
London
Under Maintenance
90 days ago
99.73
% uptime
Today
Tokyo
Under Maintenance
90 days ago
99.95
% uptime
Today
Sydney
Under Maintenance
90 days ago
99.95
% uptime
Today
Singapore
Operational
90 days ago
99.95
% uptime
Today
Canada
Under Maintenance
90 days ago
99.95
% uptime
Today
India
Operational
90 days ago
99.95
% uptime
Today
Saudi Arabia
Under Maintenance
90 days ago
100.0
% uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Related
No incidents or maintenance related to this downtime.
We will performing maintenance on some few EMS instances. Most customers will find maintenance transparent. For rare cases this may result in short-term access disruptions, GUI access delays, etc. We apologize for any inconvenience this may cause, and thank you very much for your continued support. Posted on
Apr 02, 2025 - 18:33 UTC
Completed -
The scheduled maintenance has been completed.
Apr 3, 18:01 UTC
In progress -
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 3, 16:00 UTC
Scheduled -
We will performing maintenance on some few EMS instances. Most customers will find maintenance transparent. For rare cases this may result in short-term access disruptions, GUI access delays, etc. We apologize for any inconvenience this may cause, and thank you very much for your continued support.
Apr 2, 18:31 UTC
Completed -
The scheduled maintenance has been completed.
Apr 2, 21:30 UTC
In progress -
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 2, 19:00 UTC
Scheduled -
We will be performing our weekly system maintenance from 12:00pm - 2:30pm PDT on (07:00pm-9:30pm GMT Wednesday). You should still be able to access the site, but some functionality may be temporarily unavailable. We apologize for any inconvenience this may cause, and thank you very much for your continued support.
Mar 25, 21:45 UTC