Scheduled Maintenance

Scheduled for Sep 24, 03:00 - 07:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 16, 2026 - 17:41 UTC

Scheduled

We will be performing scheduled maintenance to improve the reliability and performance of our services.
Service Impact: Users may experience brief service interruptions during the maintenance window.

Thank you for your understanding and cooperation.
Posted Sep 16, 2026 - 17:32 UTC
This scheduled maintenance affects: Canada.