US FortiClient Cloud Plano Data Center Beckend

Incident Report for FortiClient Cloud

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 10:03 UTC

Investigating

There is currently an issue at backend on US and the team is investigating.
Posted Aug 29, 2025 - 03:42 UTC
This incident affected: US.